PHP 5.6 with WPI on IIS 8.5 (Server 2012 R2)

28 Jan

If installing PHP 5.6 on IIS 8.5 (I used the Web Platform Installer on Server 2012 R2) you will see an error (if you run php-cgi.exe directly) along the lines of:

Cannot find MSVCR110.dll

To resolve this, download x64_msvcr110 and place it in:

  • c:\Windows\SysWOW64

That should do it, if not, download x32_msvcr110 and place it in:

  • c:\Windows\System32

You shouldn’t need to reboot it either.